Audio and video sync issues are often caused by problems with either hardware or software, audio devices, and settings.

Let’s go over few troubleshooting steps:

  • Check if the proper devices are chosen as audio input in your software/hardware settings.

  • Make sure your audio settings are set to the most common AAC audio codec with 44100kHz frequency, sometimes using 48000kHz may cause sound problems (including sound offset) on some devices or services.

  • If the issues present only on some streaming services, which is most likely caused by the processing on their side, make sure your audio settings are in tune with that particular service requirements. 

  • Try restarting the device/s. Often issue could be with the one-off sync problem, that can be easily removed by resetting of the system

  • Check if the sound is coming to OBS. If the sound is not coming to OBS, most probably there is some issue with your hardware settings

  • Check if the stream is playing back on the same device that does the encoding

  • If you are streaming from Studio, you can refresh the page as the lag could have been caused by the Internet.

If you conducted all the above and the issue still persists when streaming to all platforms, most probably the issue is with an audio mixer or advanced audio properties. 

You can fix it by following the steps outlined here.

If the issue still persists, please contact support. It would help us a lot if you could outline in the chat all the steps that you have tried to fix the issue.


Would you like to learn some tricks from the community?

Join our Discord and Twitter.

Can't find the right answer?

Contact the Restream Support team via our 24/7 Live Chat.

Did this answer your question?